Customizing and Using Mozilla Thunderbird 2.0

This document will cover the most popular features and settings in Mozilla Thunderbird v2.0.  If you have not already installed and configured it for your Lehigh e-mail, visit this page for setup instructions, http://www.lehigh.edu/computing/docs/tb2setup/index.htm, then return here to customize it.

To launch Thunderbird, click Start > All Programs > Mozilla Thunderbird > Mozilla Thunderbird, or double-click the Thunderbird icon

Customizing the Toolbar

By default, the Toolbar looks like this. This version of Thunderbird includes two new toolbar buttons, Back and Forward, allowing navigation through message history.

 

You can add or delete buttons by using the Customize feature. Click View > Toolbars > Customize. Drag and drop icons into or out of the Toolbar as desired, then click OK.

 

Folder Pane View:  You can customize Thunderbird to show expanded columns in the folder pane (upper left area of your screen). Turning this feature on creates a new heading above your mail folder list . When you click it, you can choose characteristics of folders that you want to appear next to each folder, such as the total number of read and unread messages and the folder's total size. To enable this feature, click Tools > Options > Advanced > General. Check the box "Show expanded columns in the folder pane" and click OK.

When the new icon appears just above your mail folders, click it and select the characteristics you want to see. Choosing the Size option is very helpful if you are trying to clean up your mail and want to quickly locate the folders taking up the most room on your mail account (usually Sent and Trash).

 

Back to top

Folder views and features

New feature! Thunderbird 2 allows you to switch between four folder "views": All (default), Unread (containing unread emails), Favorites (see below for more on Favorites), and Recent (email folders recently visited). To toggle between these folder views, click the left or right arrows or click View > Folders > All/Unread/Favorites/Recent. As with filing messages in recent folders, the list of recently used folders is updated only after Thunderbird is closed and restarted.

How does a folder become a Favorite? Unlike Recent Folders, which are tracked by Thunderbird, Favorite Folders are set by the user. To make a folder a Favorite, right-click the folder name and click Favorite Folder. To remove it as a favorite, right-click again and click Favorite Folder to remove the checkmark. Your Inbox is a Favorite Folder by default.

 

Back to top

New mail notifications

Improved feature: New mail notification alerts are improved over the last version. New mail alerts are no longer simply pop-up envelope icons , as in previous versions. Now they're much larger and contain information such as the subject, sender and message preview text.

 

If you don't want to be notified when new mail has arrived, click Tools > Options > General. Uncheck either or both boxes for "Show an alert" or "Play a sound." Then click OK. Note: Even if you uncheck both boxes, Thunderbird will still display the small envelope icon in the lower right of your screen.

If you do want to show alerts, but want to limit the kind of information displayed, click the Customize button and check only what you want to see. Click OK.

 

Back to top

Reading messages

The list of messages appears in the top right-hand panel.  When you click once on a message it displays in the bottom right-hand panel. (Double-clicking will display the message in a new window.)

To change the message view layout, click View > Layout, and choose either Classic, Wide, or Vertical View.

Back to top

Attachments

Attachments are listed beneath your mail message. To save an attachment, right-click on its name and choose Save As. (To open it, either double click it, or right-click and choose Open). If you receive more than one attachment and you want to save them all at once to the same location, right-click on any one file and choose Save All.

Thunderbird offers two options for handling attachments, Delete and Detach.  Both options should help users minimize disk quota overages by permitting the removal of attachments, but allowing the message to stay in its original state, sans attachment.  There are important differences between the options, as described below.  Use care in your selection.

       

Use Delete when you either have no need for the attachment, or have already used the Save As feature to save the file outside of your email.  Right-click an attachment, then click Delete.  You will need to confirm that you want to permanently delete the attachment(s) from the message.  You will never be able to retrieve the deleted attachment again, so use caution here (or simply save the attachment elsewhere first).

After you confirm deletion, notice what happens in your Inbox. You'll see that the message is duplicated, but the file size is much smaller in the duplicate message because now the attachment is gone (63k vs 2k).

 

When you check mail again, or close and re-open Thunderbird, the original message with its attachment is gone, replaced only by the new, smaller message that shows two files have been deleted (denoted by "Deleted:filename")

 

 

Right-click an attachment and choose Detach.  You will be prompted to save the attachment to some folder location.  The My Documents folder is recommended.

          You will need to confirm that you want to permanently delete the attachment(s) from the message.

         

          Again, after you confirm deletion, notice what happens in your Inbox. You'll see that the message is duplicated, but the file size is much

smaller in the duplicate message because now the attachment is gone (43k vs 2k).



When you check mail again, or close and re-open Thunderbird, the original message with its attachment is gone, replaced only by the new, smaller message that shows what appears to be the attachment.

However, if you double-click the attachment, Thunderbird will attempt to open it at the location where you saved it when you detached it.  If you moved the file from its original save location, you will see a message like this:

If you encounter this problem, simply search for the file in the location you moved it to.  Or, use the Windows Explorer Search function (right-click the Start button, left-click Search) to locate the file by its name, which will be noted in the email message.

 

Back to top

Image blocking

By default, Thunderbird blocks remote images and other content in messages from people you don't know. This protects your privacy because spammers can use remote content to detect if and when you've viewed a message from them, and thus to verify your e-mail address and send you more spam.

When you receive a message with remote images, Thunderbird will display an alert stating that remote images have been blocked, and the images in the message body will be replaced with simple place-holders (red dot in empty white box).  If you want to view the remote images -- for example, if you subscribe to an e-mail newsletter that regularly includes remote images (as in below example) -- click the Load Images button that appears to the right of the alert message.

 

Back to top

Email scam checking

By default, Thunderbird has a built-in scam and phishing sensor to help protect users from email scams.  This is a message Thunderbird thinks is a scam.  If you recognize a message as legitimate, click the Not a Scam button to train Thunderbird that this message is OK and not to mark future messages from this source as a potential scam.

 

Back to top

Sorting messages

Clicking any one of the column headings will sort messages by that characteristic (Sender, for example). Clicking once more reverses the sort order.

 

 

To add or remove headings, click the square icon at the far right end of the header list .  Check or uncheck characteristics you want to see or be removed. Most users check Status and Size, and uncheck Junk Status.

 

  More about the Junk feature:   Thunderbird includes a built-in junk filter that attempts to determine whether or not a message is junk (such as spam). Lehigh already filters all incoming mail and determines whether or not a message is spam, and tags it as such if the message meets certain criteria. You do not need to "train" Thunderbird to tag junk mail, so you do not need to display this characteristic in your message list.  For more on Lehigh spam filtering, see http://www.lehigh.edu/helpdesk/faq/qa/spamassassin.shtml

Sorting by thread: On the left side of the message list there is a Thread header (unless you uncheck that characteristic) that lets you sort your messages by threads, so you can follow all the messages in a particular email exchange in order.  This is not the same as sorting by Subject.  Sorting by thread will include all messages in an exchange, even if a person changes the Subject heading at some point in the exchange(s). In this example, sorting strictly by Subject would have yielded one less message in the sorting of this exchange.

Sort by group: For users who want to sort messages by date and want them grouped by periods of time, click View > Sort by > Grouped by sort G, or more simply, press G on the keyboard. Notice how the messages appear in categories Today, Yesterday, Last Week, Two Weeks Ago, and Old Mail. Click the [+] sign to expand a group of messages; click the [-] sign to collapse the group. Some users find themselves in this mail sort accidentally because they've pressed the letter G by mistake. To unsort messages by group, click on the column heading you want to sort by, such as Date.

Back to top

Searching messages

To search for one or more email messages within your email folders, right-click on YourUserID@lehigh.edu at the top of your folder list, and left-click Search. Or, click Edit > Find > Search Messages.

 

 

Choose whether to search for messages that match all or any of your search criteria. Click the [+] button to add multiple search terms/qualifiers. When you click Search, the search will produce results in the bottom of the window.  Double-click on them to view, or select them and file or delete them.  In this example, messages must match two criteria. There are likely other "firewall" messages in the mail account, but this search was limited to only the bulletins that were sent by a certain person.

 

Saving your searches: Thunderbird allows you to create Saved Search folders. A Saved Search folder looks like a regular mail folder but when you click on it, it runs a search according to criteria that you've set previously and it displays a list of messages that match those criteria. For example, you could create a Saved Search folder that lists all the messages received from a certain person over the past 30 days, even if those messages are stored in different folders and subfolders. For comprehensive instructions on creating and modifying saved searches, see the Mozilla FAQ article on saved searches.

Quick searching: If you want to perform a quick search on a single folder (without saving your search), use the View box. If you don't have this box, add it via Customizing the Toolbar (drag and drop Mail Views to your toolbar).

 

For example, you could search for only those messages that have attachments by clicking the down arrow and choosing Has Attachments. You can also choose to view messages tagged a certain way, such as Important (View > Tags > Important).

 

You can create custom quick searches by choosing Custom from the View pull down menu. This example shows how to create a new search that displays mail received within the last 10 days.  Click Customize > New. Type in a Message View Name, such as Last 10 Days. Enter the criteria shown below, then click OK.

Click OK to exit the Customize Message Views window. A new search called Last 10 Days will appear in your Views list.

 

Back to top

Tagging messages

You can color-code your mail using tags. In addition to making them more visible, you can use the View feature to quickly sort messages by those that are tagged a certain way. If you don't have a View button in your toolbar, see Customizing the Toolbar. You can set more than one tag per message.

Choose one of these three ways to tag a message:

 

 

The message labeled "To Do " now shows in blue in your message list. 

To change the colors or tag names used for coding, click Tools > Options > Display > Tags . Change label characteristics as desired, then click OK.

 

Back to top

Deleting mail and managing Trash

To delete mail, select one or more messages and click the Delete button in the toolbar, or press the Delete key on your keyboard.

It's possible to un-do a deletion, but ONLY if you have not closed down Thunderbird. To un-do a deleted message, click Edit > Undo Delete Message .

 

There are three options for how Thunderbird will handle deleted mail: Move it to the Trash folder, Mark it as deleted, and Remove it immediately.  To change this option, click Tools > Account Settings > Server Settings. Choose a delete action, then click OK.

A word about the Trash folder: As part of mail management, it may be tempting to consider storing needed email in the trash folder. Whether it is the Windows desktop Recycle Bin, or the MacOS desktop Trash can, or the Trash folder within the email program, the TRASH is not an ordinary location. It represents space that is occupied by something no longer needed; space that is specifically marked to be reclaimed. In other words, items in the trash have been DELETED. Items in the trash continue to exist only to allow for possibly undoing the deletion in case it was done by mistake (and users should not count on the grace period for deciding to undo this mistake to last for too long). It should not be a shock when items in the trash are lost; presumably, that's why they were put there. If the real need is for a temporary storage location for items that are pending review, see Creating New Folders for instructions on creating a separate location for that specific purpose.

Back to top

Filters

Examples: LISTSERVs and SPAM

Example 1: Listserv messages moved to another folder

A mail filter is used to automatically move, delete or forward your incoming e-mail messages based on pre-set criteria. For example, you may want to have all e-mail coming from a certain person, organization or listserv filed in a separate folder for later viewing. To create a mail filter, click Tools > Message Filters, then click the New button. Give your filter a name, choose the filter criteria and an action to take on those messages. When finished creating your filter, click OK, then close the Message Filters box. Below is an example of a filter that moves mail from the Lehigh WIRED listserv to a folder called wired-i.

Example 2: SPAM messages moved to Trash

A popular filter is one that moves SPAM messages to the Trash folder (or some other folder to be reviewed later).   The following example shows the criteria used to move SPAM to Trash. To create a spam filter, click Tools > Message Filters, then click the New button. Name it Spam Filter and then set the filter criteria and an action to take on those messages. When finished creating your filter, click OK, then close the Message Filters box. Note: Some users like to create a mail folder called "Spam" and move messages there, instead of deleting it. It's a matter of personal preference how you act on spam.

 

Back to top

Folders

Take control of your mail by using folders

If you tend to keep hundreds of messages in your Inbox, consider building a folder system.  Moving messages out of your Inbox and into other folders increases the likelihood of finding messages more quickly when you need them. To move a message into a folder, select it, click the File button in the Toolbar and choose either YourUserID@lehigh.edu or Local Folders. Clicking YourUserID@lehigh.edu displays all of your folders on the mail server. Local Folders shows just the folders on your hard disk.  Select the folder where you want to move the message.

Notes

New Feature! This version of Thunderbird offers a new feature that makes filing messages quicker and easier. As you move from folder to folder in your mail, Thunderbird keeps a running list of these folders in the recent folders list. When you use the File button to move a message from one folder to another, you will see a Recent menu, showing the 15 most recently-used folders for quicker access. However, this list is only refreshed when you close and reopen Thunderbird.

To file a message into a folder that does not appear in the Recent list, simply choose the email account where the folder is found, then click the folder you want to store the message in.

 

Creating New Folders

To create a new folder on the mail server, right-click YourUserID@lehigh.edu and click New Folder. Or, click File > New > Folder.

 

Other mail management tips:

 

Back to top

 

Signature files

You can set up Thunderbird to automatically append a signature file to all of your email. LTS discourages the use of images as a signature file because they can make your email messages many times larger than a message with a simple text signature. Unnecessarily large emails eat into not only your mail quota (on the sending side), but also your recipient's quota (on the receiving side). In addition, some mail programs do not render image signatures perfectly, so it's best to use plain text to ensure readability.

Sample signature file:

Kathleen M. Frederick
Sr. Computing Consultant
Library and Technology Services
Lehigh University
Phone: 610-758-5796

http://www.lehigh.edu/lts/teams/cbe/

To create a signature file:

  1. Open Notepad (or another text editing program) on your computer. On Windows XP computers Notepad will be under Start > All Programs > Accessories).
  2. In Notepad, type in your signature file as you would like it to appear. Be sure to use carriage returns to separate lines. URLs entered as text will appear as hyperlinks to email recipients.
  3. Save the file on your C: drive (we suggest My Documents). Make sure the file has the .txt file extension, so that it will be readable by the email program.
  4. Close Notepad.

To configure Thunderbird to use this file, click Tools > Account Settings

Back to top

Sending messages

To create a new message, click the Write icon.

To reply to an existing message, click the Reply or Reply All icons. (Reply All sends a message to everyone who received the original message).

Enter the email address(es) to send to in the address box. You can choose different types of addressing, such as To:, Cc:, and Bcc: (Bcc, short for blind copy, is a copy of a message sent to a recipient without the recipient's email address appearing in the message. This is useful if you want to copy a message to many people without each of them seeing who the other recipients are.)

Enter a subject in the Subject line and the body text in the main section. Use special formatting, such as boldface or bulleting, if desired.  Notice that if you have a signature file created and configured in Thunderbird, it already appears within the body of the message.

When ready to send, click the Send icon.

Attachments: To attach a file to an email message, click on the Attach icon in the composition window.   Select the file you want to attach and click Open. The file name will be displayed in the list of attachments in the upper right of the Composition window. To remove an attachment before sending, click on it and press the Del key, or right-click the filename and choose Delete.

Mail composition tip: Ever compose a long email with a lot of links and wonder how it might look to the recipient?  Save it to the Drafts folder before sending.  This gives you an opportunity to check that hyperlinks work, lines wrap properly, etc., while you still have the composition window open.  To save a message to Drafts while composing, click File > Save as > Draft. To view the message, go to your Drafts folder and select the message.

New Feature!  You can have Thunderbird automatically save messages to the Draft folder while you are composing them.  To turn this feature on, click Tools > Options > Composition.  Click the General tab and click the box for "Auto Save every [  x  ] minutes."  Set a time interval to perform saves, then click OK.  Saved drafts will not accumulate in the Drafts folder. When you send the message, the draft copy is automatically cleared from the folder.

 

Back to top

Templates

If you find yourself retyping the same sorts of messages in response to routine requests, create a message without addressing it and save it as a template. File > Save as > Template. Then when you need to reply with that message, go to your Templates folder, double-click the template message, address it, edit if necessary, and click Send. Templates remain in the templates folder until or unless you delete them.

Back to top

Spell checking

Thunderbird includes an inline spellchecker that checks your spelling as you type. This feature is turned on by default. Thunderbird underlines words in red that it doesn't find in its dictionary. It also checks for misspelled words in the Subject heading. If you right-click on a word, you'll see a few suggestions (if it has any) on how you might spell the word correctly, and also offers the option of adding the word to the dictionary if the word is spelled correctly but simply doesn't exist in Thunderbird's dictionary.

If you prefer, you can use spellchecker on an "as needed" basis via the Spell button on the Composition window Toolbar.  If you want to spell check every message you send, click Tools > Options > Composition, click the Spelling tab and check the box for "Enable spell check as you type," then click OK.

 

Back to top

Saving your password

When you launch Thunderbird, and when you send your first outgoing message for a session, you will be asked to enter your email password, but you can have Thunderbird remember it so you don't have to re-enter it each time you access your email. Warning: This feature is not recommended unless your PC is in a secure area, turned off when unattended, and protected by a login.  If it is secure and you want to enable password saving, click the checkbox "Use Password Manager to remember this password" on the login screen, enter your password, then click OK.

When you change your password : Every six months, Lehigh faculty, staff, and students are prompted to change their password for security purposes. The Help Desk frequently gets calls from users who report that their email has stopped working once they change their password. In most cases, the problem is that users have enabled password saving.  If you do use this feature, when you change your password you'll have to take a few extra steps:

      

      

 

Back to top

Other Settings

Forwarding as Inline rather than attachments:

You have two options for forwarding mail messages, Inline or As attachment.  When you choose "Inline" you have an opportunity to edit the forwarded message, such as when you want to remove irrelevant text from the original message.  When you choose "As attachment" there is no opportunity to modify the text of the forwarded message.  It is sent in its entirety. To change this setting, go to Tools > Options > Composition. Choose your preference in the Forward messages: field , then click OK.

 

Positioning your replies:

You have several choices for how to position your text when replying to messages.  Choose your preference at Tools > Account Settings > Composition & Addressing.  You can start your reply and place your signature above or below the quoted message. After you make your choice(s), click OK.

 

New feature! Saving replies in the folder of the message being replied to:

Thunderbird saves all sent mail to the Sent folder (either on the server, or in Local Folders, depending on your preference). From an organizational standpoint, some users might find it helpful to instead save replies in the same folder of the message being replied to. This is typically your Inbox, but works the same way when replying to a message that's been filed in another folder. To use this feature, click Tools > Account Settings > Copies & Folders. Place a checkmark in the box for "Place replies in the folder of the message being replied to," then click OK.

Back to top

 

Mass emailing the easy way

If you have a spreadsheet that contains a column of email addresses, Thunderbird lets you email that group of people simply by pasting the column of addresses into the "To:" field in a Composition window. You do not need to make an email list first if you don't need one.

However, if the data you want to paste is a list of only 4- or 6-digit Lehigh IDs, you must first append "@lehigh.edu" to all the IDs. All mass email messages must be sent to full email addresses. Failure to do so can result in the wrong person or people receiving your email!

This is because when Thunderbird searches 4-digit IDs against the Lehigh directory, it automatically selects a 6-digit ID if it finds one that starts with the same 4-digits. For example, you may intend to email user "aaa4."  But if there is a user with the ID "aaa405" that person would receive the email message instead.

Follow these instructions http://www.lehigh.edu/computing/docs/thunderbird/Concat.htm for making full addresses from Lehigh User IDs, then return to this page to continue with the process of emailing the list.

 

Step 1: Select the column of email addresses from your file, right-click and Copy. BE SURE THE ADDRESS IS A COMPLETE ADDRESS in the form UserID@someplace.xxx.  There can be no blank or incomplete cells, or sending of your message will fail.

 

Step 2: In a Composition window, right-click in the To: field and click Paste.  Note: Use the Bcc: field if you prefer to conceal the identities of recipients from one other.

 

The results will look like this:

 

Step 3 : Press ENTER. When you press ENTER, notice each email address will appear on its own line. This is an important step, as sending a message with too many addresses in the first row may fail.

Step 4: Click Send.

 

Back to top

Adding another email account to your profile

If you monitor an additional email account for your department, such as an "IN" account, you can add it to your profile so that you can access both accounts within the same Thunderbird session. For instructions, see: http://www.lehigh.edu/lts/teams/act/Mozilla/addacct.htm

Back to top

Themes

Themes change the look and feel of Thunderbird. If you want to change the default theme, click Tools > Add-ons > Themes > Get Themes

 

Browse the selection until you find one you like, then follow the on-screen instructions. Do not click Install Now. You must follow the "How to Install in Thunderbird" directions. When instructed to "right-click the link below," this refers to the Install Now button. Save the file to your Desktop.

 

After you've saved the installer file to the Desktop, go back to Tools > Add-ons > Themes and click the Install button.

Locate and select the file you saved to the Desktop, then click Open.

Click Install Now to install the theme.

 

Email overwhelming you? Check out Reclaim your Workday! 10 Ways to Manage your Email

 

kmm3, Last updated January 21, 2010