Customizing and Using Mozilla Thunderbird 1.0.x

This document will cover the most popular features and settings in Mozilla Thunderbird.  If you have not already installed and configured it for your Lehigh e-mail, visit this page for setup instructions, http://www.lehigh.edu/helpdesk/docs/thunderbird/index.html, then return here to customize it.

To launch Thunderbird, click Start > All Programs > Mozilla Thunderbird > Mozilla Thunderbird, or double-click the Thunderbird icon

Customizing the Toolbar

By default, the Toolbar looks like this:

You can add or delete buttons by using the Customize feature. Right-click in an empty area of the Toolbar and click Customize. Drag and drop icons into or out of the Toolbar, as desired, then click OK.

 

Folder Pane View:  You can customize Thunderbird to show expanded columns in the folder pane (upper left area of your screen). Turning this feature on creates a new heading above your mail folder list . When you click it, you can choose characteristics of folders that you want to appear next to each folder, such as the total number of read and unread messages and the folder's total size. To enable this feature, click Tools > Options > Advanced. Check the box "Show expanded columns in the folder pane" and click OK.

When the new icon appears just above your mail folders, click it and select the characteristics you want to see. Choosing the Size option is very helpful if you are trying to clean up your mail and want to quickly locate the folders taking up the most room on your mail account (usually Sent and Trash).

Back to top

Reading messages

The list of messages appears in the top right-hand panel.  When you click once on a message it displays in the bottom right-hand panel. (Double-clicking will display the message in a new window.)

To change the message view layout, click Tools > Options, choose the window configuration you prefer and click OK, or click View > Layout, and choose either Classic, Wide, or Vertical View.

Attachments are listed beneath your mail message. To save an attachment, right-click on its name and choose Save As. (To open it, either double click it, or right-click and choose Open). If you receive more than one attachment and you want to save them all at once to the same location, right-click on any one file and choose Save All.

 

Image blocking: By default, Thunderbird blocks remote images and other content in messages from people you don't know. This protects your privacy because spammers can use remote content to detect if and when you've viewed a message from them, and thus to verify your e-mail address.

When you receive a message with remote images, Thunderbird will display an alert stating that remote images have been blocked, and the images in the message body will be replaced with simple place-holders (red dot in empty white box).  If you do want to view the remote images -- for example, if you subscribe to an e-mail newsletter that regularly includes remote images (as in below example) -- click the

"Show Images" button that appears to the right of the alert message.

 

Thunderbird's default setting is to allow the loading of remote images from people who are in your Personal Address Book. If you want to change this setting, or if you want to allow the loading of all remote images, go to the Tools > Options > Advanced > Privacy, make changes as desired and click OK.

 

Back to top

 

Sorting messages

Clicking any one of the column headings will sort messages by that characteristic (Date, for example). Clicking once more reverses the sort order.

 

 

To add or remove headings, click the square icon at the far right end of the header list .  Check or uncheck characteristics you want to see or be removed. Most users check Status and Size, and uncheck Junk Status.

 

  More about the Junk feature:   Thunderbird includes a built-in junk filter that attempts to determine whether or not a message is junk (such as spam). Lehigh already filters all incoming mail and determines whether or not a message is spam, and tags it as such if the message meets certain criteria. You do not need to "train" Thunderbird to tag junk mail, so you do not need to display this characteristic in your message list.  To turn off the junk filter feature permanently, click Tools > Junk Mail Controls. Choose the Adaptive Filter tab, uncheck the "Enable adaptive junk mail detection" box, then click OK.  For more on Lehigh spam filtering, see http://www.lehigh.edu/helpdesk/faq/qa/spamassassin.shtml

Sorting by thread: On the left side of the message list there is a Thread header (unless you uncheck that characteristic) that lets you sort your messages by threads, so you can follow all the messages in a particular email exchange in order.  This is not the same as sorting by Subject.  Sorting by thread will include all messages in an exchange, even if a person changes the Subject heading at some point in the exchange(s). In this example, sorting strictly by Subject would have yielded one less message in the sorting of this exchange.

Back to top

Searching messages

To search for one or more email messages within your email folders, right-click on YourUserID@lehigh.edu at the top of your folder list, and left-click Search Messages

 

 

Choose whether to search for messages that match all or any of your search criteria. Click More to add multiple search terms/qualifiers. When you click Search, the search will produce results in the bottom of the window.  Double-click on them to view, or select them and file or delete them.  In this example, messages must match two criteria. There are likely other "Bulletin" messages in the mail account, but this search was limited to only the bulletins that were sent by Library & Technology Services.

Saving your searches: Thunderbird allows you to create Saved Search folders. A Saved Search folder looks like a regular mail folder but when you click on it, it runs a search according to criteria that you've set previously and it displays a list of messages that match those criteria. For example, you could create a Saved Search folder that lists all the messages received from a certain person over the past 30 days, even if those messages are stored in different folders and subfolders. For comprehensive instructions on creating and modifying saved searches, see the Mozilla FAQ article on saved searches.

Quick searching: If you want to perform a quick search on a single folder (without saving your search), use the View box above your message list.

For example, you could search for only those messages that have attachments by clicking the down arrow and choosing Has Attachments. Other choices include Unread messages or ones you've labeled Important or To Do. If you want to find recent messages choose Last 5 Days.

 

You can create custom quick searches by choosing Custom from the pull down menu. This example shows how to create a new search that displays mail received within the last 10 days.  Click Customize > New. Type in a Message View Name, such as Last 10 Days. Enter the criteria shown below, then click OK.

Click OK to exit the Customize Message Views window. A new search called Last 10 Days will appear in your Views list.

 

Back to top

Labeling messages

You can color-code your mail using labels. Right-click on the message in the list, choose Label, and select Important, Personal, Work, To Do or Later. Notice the numbers to the left of each label name.  You can set labels this way as well.  Select a message and press "1" on the keyboard to label it "Important," press "2" for "Work," and so on.

 

The message labeled "Important" now shows in red in your message list.  To change the colors or label names used for coding, click Tools > Options > Display. Change label characteristics as desired, then click OK.

 

Back to top

Deleting mail and managing Trash

To delete mail, select one or more messages and click Delete.

 

There are three options for how Thunderbird will handle deleted mail: Move it to the Trash folder, Mark it as deleted, and Remove it immediately.  To change this option, click Tools > Account Settings > Server Settings. Choose a delete action, then click OK.

The most common option is Move it to the Trash folder. For times when you want to immediately delete a message from the mail server (and skip the Trash folder), select it and press [Shift] + [Del]. This is particularly helpful if you are over quota and want to quickly make more room. Use caution here, as you will not be able to retrieve a message from the Trash folder if you choose this delete method. It won't be there!

A word about the Trash folder: As part of mail management, it may be tempting to consider storing needed email in the trash folder. Whether it is the Windows desktop Recycle Bin, or the MacOS desktop Trash can, or the Trash folder within the email program, the TRASH is not an ordinary location. It represents space that is occupied by something no longer needed; space that is specifically marked to be reclaimed. In other words, items in the trash have been DELETED. Items in the trash continue to exist only to allow for possibly undoing the deletion in case it was done by mistake (and users should not count on the grace period for deciding to undo this mistake to last for too long). It should not be a shock when items in the trash are lost; presumably, that's why they were put there. If the real need is for a temporary storage location for items that are pending review, see Creating New Folders for instructions on creating a separate location for that specific purpose.

Back to top

Mail Filters

A Mail Filter is used to automatically move, delete or forward your incoming e-mail messages based on pre-set criteria. For example, you can have all e-mail tagged as SPAM moved to your Trash folder (or some other folder to be reviewed later) by setting up a mail filter. To create a mail filter, click Tools > Message Filters, then click the New button. Give your filter a name, choose the filter criteria and an action to take on those messages.  The following example shows how to establish rules for a filter that moves spam messages to Trash. When finished creating your filter, click OK, then close the Message Filters box. 

 

Back to top

Folders

Take control of your mail by using folders

If you tend to keep hundreds of messages in your Inbox, consider building a folder system.  Moving messages out of your Inbox and into other folders increases the likelihood of finding messages more quickly when you need them.  At the same time, it helps keep you from exceeding your Inbox quota (20MB for all users).  To move a message into a folder, select it, click the File button in the Toolbar and choose either YourUserID@lehigh.edu or Local Folders. Clicking YourUserID@lehigh.edu displays all of your folders on the mail server. Local Folders shows just the folders on your hard disk.  Select the folder where you want to move the message.

Notes

 

Other mail management tips:

Creating New Folders

To create a new folder on the mail server, right-click YourUserID@lehigh.edu and click New Folder.

 

Back to top

 

Signature files

If you don't already have a signature file, now is a good time to create one. You can set up Thunderbird to automatically append a signature file to all of your email, saving you the step of typing it yourself. Sample content for a signature file:

Kathleen M. Frederick
Sr. Computing Consultant
Library and Technology Services
Lehigh University
Phone: 610-758-5796

http://www.lehigh.edu/lts/teams/cbe/

To create a signature file:

  1. Open Notepad (or another text editing program) on your computer. On Windows XP computers Notepad will be under Start|All Programs|Accessories).
  2. In Notepad, type in your signature file as you would like it to appear. Be sure to use carriage returns to separate lines. URLs entered as text will appear as hyperlinks to email recipients.
  3. Save the file on your C: drive. Make sure the file has the .txt file extension, so that it will be readable by the email program.
  4. Close Notepad.

To configure Thunderbird to use this file, click Tools > Account Settings

Back to top

Sending messages

To create a new message, click the Write icon.

To reply to an existing message, click the Reply or Reply All icons. (Reply All sends a message to everyone who received the original message).

Enter the email address(es) to send to in the address box. You can choose different types of addressing, such as To:, Cc:, and Bcc: (Bcc, short for blind copy, is a copy of a message sent to a recipient without the recipient's email address appearing in the message. This is useful if you want to copy a message to many people without each of them seeing who the other recipients are.

Enter a subject in the Subject line and the body text in the main section. Use special formatting, such as boldface or bulleting, if desired.  Notice that if you have a signature file created and configured in Thunderbird, it already appears within the body of the message.

When ready to send, click the Send icon.

Attachments: To attach a file to an email message, click on the Attach icon in the composition window.   Select the file you want to attach and click Open. The file name will be displayed in the list of attachments in the upper right of the Composition window. To remove an attachment before sending, click on it and press the Del key, or right-click the filename and choose Delete.

Mail composition tip: Ever compose a long email with a lot of links and wonder how it might look to the recipient?  Save it to the Drafts folder before sending.  This gives you an opportunity to check that hyperlinks work, lines wrap properly, etc., while you still have the composition window open.  To save a message to Drafts while composing, click File > Save as > Draft. To view the message, go to your Drafts folder and select the message.

Back to top

Templates

If you find yourself retyping the same sorts of messages in response to routine requests, create a message and save it as a template. File > Save as > Template. Then when you need to reply with that message, go to your Templates folder, double-click the template message, edit if necessary, and send it out.   Templates remain in the templates folder until or unless you delete them.

Back to top

Spell checking

Thunderbird includes a built-in spell checker that you can use on an "as needed" basis via the Spell button on the Composition window Toolbar.  If you want to spell check every message you send, click Tools > Options > Composition and click on the checkbox for "Check spelling before sending" and click OK.

Back to top

Saving your password

When you launch Thunderbird you will be asked to enter your email password, but you can have Thunderbird remember it so you don' t have to re-enter it each time you access your email. Warning: This feature is not recommended unless your PC is in a secure area, turned off when unattended, and protected by a login.  If it is secure and you want to enable password saving, click the checkbox "Use Password Manager to remember this password" on the login screen, enter your password, then click OK.

When you change your password : Every six months, Lehigh faculty, staff, and students are prompted to change their password for security purposes. The Help Desk frequently gets calls from users who report that their email has stopped working once they change their password. In most cases, the problem is that users have enabled password saving.  If you do use this feature, when you change your password you'll have to take a few extra steps:

 

          

      

      

Back to top

Other Settings

Forwarding as Inline rather than attachments:

You have two options for forwarding mail messages, Inline or As attachment.  When you choose "Inline" you have an opportunity to edit the forwarded message, such as when you want to remove irrelevant text from the original message.  When you choose "As attachment" there is no opportunity to modify the text of the forwarded message.  It is sent in its entirety. To change this setting, go to Tools > Options > Composition. Choose your preference, then click OK.

Positioning your replies:

You have several choices for how to position your text when replying to messages.  Choose your preference at Tools > Account Settings > Composition & Addressing.  You can start your reply and place your signature above or below the quoted message. After you make your choice(s), click OK.

 

New mail notification:

By default Thunderbird will notify you that a new message has arrived in your Inbox by displaying a pop-up in the lower right area of your screen, like this:

 

If you find this pop-up distracting, you can turn it off.  Click Tools > Options > General.

 

Back to top

 

Mass emailing the easy way

If you have a spreadsheet that contains a column of email addresses, Thunderbird lets you email that group of people simply by pasting the column of addresses into the "To:" field in a Composition window. You do not need to make an email list first if you don't need one.

However, if the data you want to paste is a list of only 4- or 6-digit Lehigh IDs, you must first append "@lehigh.edu" to all the IDs. All mass email messages must be sent to full email addresses. Failure to do so can result in the wrong person or people receiving your email!

This is because when Thunderbird searches 4-digit IDs against the Lehigh directory, it automatically selects a 6-digit ID if it finds one that starts with the same 4-digits. For example, you may intend to email user "aaa4."  But if there is a user with the ID "aaa405" that person would receive the email message instead.

Follow these instructions http://www.lehigh.edu/computing/docs/thunderbird/Concat.htm for making full addresses from Lehigh User IDs, then return to this page to continue with the process of emailing the list.

 

Step 1: Select the column of email addresses from your file, right-click and Copy. BE SURE THE ADDRESS IS A COMPLETE ADDRESS in the form UserID@someplace.xxx.  There can be no blank or incomplete cells, or sending of your message will fail.

 

Step 2: In a Composition window, right-click in the To: field and click Paste.  Note: Use the Bcc: field if you prefer to conceal the identities of recipients from one other.

 

The results will look like this:

 

Step 3: Click Send.

 

Back to top

Adding another email account to your profile

If you monitor an additional email account for your department, such as an "IN" account, you can add it to your profile so that you can access both accounts within the same Thunderbird session. For instructions, see: http://www.lehigh.edu/lts/teams/act/Mozilla/addacct.htm

Back to top

 

kmm3, Last updated January 20, 2006