Introduction to the Mozilla Suite

What is the Mozilla Suite?

Mozilla Suite is the open-source (free, cooperative development) offshoot of Netscape. It incorporates a web browser, an email client and a web page editor. Mozilla's functionality and 'look and feel' are quite similar to Netscape 4.x and 7.x versions.

How do I get Mozilla?

To install the Mozilla Suite go to http://www.mozilla.org/products/mozilla1.x/ and click the link for your operating system in the green Download Now box.
Instructions for configuring Mozilla for Lehigh email here: http://www.lehigh.edu/helpdesk/mozilla/mozillamail.html

Using the Mozilla Web Browser

Using Mail

Navigating web pages with Mozilla


To open Mozilla, either go to your programs menu and choose the Mozilla folder, then Mozilla within the folder, or on the public sites, click the red lizard "Mozilla" icon in the taskbar at the bottom of the screen.

To follow a link (most links are displayed as blue and underlined, but any time you move your cursor over something on the page and it becomes a pointing hand, you can click on the link), click on it.

If the M box in the upper right corner is still animated, the page is still downloading.

To go backward, use the Back button Back button . If you back up too far, you can use the Forward button Forward Button .
To back up or go forward more than one step, click the drop-down arrow next to the back or forward button to get a list of sites to choose from.

You can also right-click either button to see a list of pages you've visited during your browsing session.

The location bar at the top of the window shows the URL (web page address) of the site you are looking at.

 

To go to a particular site, you can type the site's URL in the location bar and press Enter. (To select the whole contents of the Location bar at once, press Ctrl-L.) . If you click on the down-arrow next to it, you will see a list of any URLs you have typed in.

Back to top


Searching


You can do a search directly from the Location Bar, too. Just type in the terms you want to search for, then click the Search Search Button button, and the browser will have the search done in the default Web search engine. To change the search engine: go into the Edit menu and choose Preferences. Click on the plus sign next to Navigator, choose Internet Search.

To find a specific piece of text in the page you are on, press: Ctrl-F and enter the text to find. Find again: Ctrl-G.

Back to top


Tabbed Browsing

One of Mozilla's most convenient features is Tabbed Browsing.  When you visit more than one page at a time, you can use Tabbed Browsing to navigate the Web faster and easier.  Tabbed Browsing lets you open tabs, each displaying a web page, within a single Mozilla window. You don't have to have several windows open to visit several different web pages. This frees up space on your desktop. You can open, close, and reload web pages conveniently in one place without having to switch to another window.

For example, if you are already viewing Lehigh's Help Desk web page and want to keep that page active while opening the Guide to Using Spybot, right-click that link and choose Open Link in New Tab or click the middle mouse button (scroll wheel).

Notice that both pages are within view in a single browser window, with each page accessible via its respective tab at the top of the window.

To toggle between pages, simply click on a tab.  To close one or more tabs, right-click on the tab and choose Close Tab or Close Other tabs. 

If you want to open a new tab without linking from a page already in view, right-click an empty area next to your existing tabs and choose New Tab. The tab remains "Untitled" until you enter a URL in the Location bar and press Enter. Mozilla loads that URL to the new tab.

 

Back to top


Setting your homepage:


Clicking the Home button Home Icon takes you back to the 'home' page you have set in Mozilla.

To set the home page, Edit > Preferences. In the Home Page section, put the URL of the web page you want to be the home page for Mozilla for you:

Set homepage

Back to top



Bookmarks:

To bookmark a favorite website to return to, right click on the page and choose 'Bookmark this Page'. It will be added to the list of bookmarks that appear when you click on the Bookmarks icon Bookmarks Icon


If you want to put a new bookmark directly into a folder, click on the bookmark icon when you are on that page, and choose File Bookmarks. You can change the default bookmark name here, as well as select or create a folder to save the bookmark in.


To change or rename bookmarks, click on the Bookmarks icon, and choose Manage Bookmarks. In this screen you can re-arrange and re-name bookmarks, create folders and search the bookmark list.


You can export and import bookmark lists by choosing the appropriate option from the Tools menu in Manage Bookmarks. Bookmarks are saved as HTML (web page) files.

Back to top


Sidebar
Mozilla can be used with a sidebar displayed. This sidebar can be used to display Search (advanced search mode, in prefs, lets you choose multiple search engines), What's related, History, and/or Bookmarks. If you don't want to use the sidebar, you can close it by clicking the close box. To get it back go to the View menu, choose Show/Hide, then Sidebar. Or Press F9.
 

Back to top


Password Saving & Management
When you go to a web page that requires a login, or when you check your email, you can choose to save the password so that logging in is automatic the next time.  For web pages, you can tell it Yes, No, or Never For This Site (which will keep it from asking again). For email, you can check the box "Use password manager to remember this password." If you saved a password by mistake, or need to change it, go to the Tools menu and choose Password Manager, then Manage Stored Passwords. From this screen you can delete saved web page or email passwords.

To turn off Password saving completely, go to the Edit menu and choose Preferences. Then click on the plus sign (+) next to Privacy and Security in the Category column on the left, and click Passwords. Uncheck the box that says 'Remember Passwords', then click OK:


Turning off Password Management

Back to top



Pop-up blocking


You can set Mozilla to not allow pages to generate 'pop-up windows', often used for ads. However, you should know that depending on which boxes you check, other services may be affected. To do this, choose Preferences from the Edit menu. Click on the plus sign (+) next to Privacy & Security. Click on Popup Windows. Check the box "Block unrequested popup windows".  

If you encounter a website that requires a popup, click the "Unblock this site's popups" icon in the lower right corner of the screen to enable it.  To see a list of sites where you've enabled popups, click Tools > Popup Manager > Manage Popups.  You can allow and disallow popups here, as needed.

Back to top

 

Using Mozilla Mail

Getting into mail: from the Window menu, choose Mail and Newsgroups. Or click the white envelope icon at the lower left area of the browser window
If you need to set up mail preferences, see: http://www.lehigh.edu/helpdesk/mozilla/mozillamail.html

Reading messages

The list of messages appears in the top right hand panel; when you click once on a message it displays in the bottom right hand panel. (Double-clicking will display the message in a new window.

To change the message view layout, click Edit > Preferences. In the left panel, expand Mail & Newsgroups, then click Windows. Choose your layout of preference on the right and click OK.

 

Back to top

Attachments

Attachments are listed in a box in the upper right area of the open mail message.  To save an attachment, right click on its name in the attachments box and choose Save As. (To open it, choose Open). If you already viewed a message with an attachment, the icon next to it will be an envelope with a paperclip instead of a green down arrow.)

 

Back to top

Sorting messages


Clicking on any one of the column headings will sort messages by that characteristic (Date, for example). Clicking it again will reverse the sort order. You can also go to the View menu and choose Sort By, then the type of Sorting (Order Received is the default).

 

 

  To see more or different properties of the messages in the list, click the little icon at the far right end of the list: Wierd mail properties icon and check the properties you want to see, and uncheck those you don't want to see.

 



Sorting by Thread: On the left side of the list (unless you uncheck it) is a Thread button that will let you sort your messages by threads, so you can follow all the messages in a particular email exchange in order. This is not the same as sorting by Subject.  Sorting by thread will include all messages in an exchange, even if a person changes the Subject heading at some point in the exchange(s). In this example, sorting strictly by Subject would have yielded one less message in the sorting of this exchange.


Back to top

Searching messages


Search Messages is under the Tools menu. Choose the folder to search, which part of the message to look in, and what to look for. (You can also search for only messages that don't contain particular information: switch the drop down menu from 'contains' to 'doesn't contain'.)  Use More to add multiple search terms/qualifiers. When you click Search, the search will be done and any messages that match will be listed in the lower part of the window. Double-click on them to display, or select them and file or delete them. 

To search within only a single mail folder, right-click the folder you want to search and choose Search Messages.

 

Back to top

Labels 
You can color-code your mail using labels. Right click on the message in the list, choose Label, and select (Important, Personal, Work, To Do or Later). You can also filter things to have the appropriate color coding.

The message labeled "Important" now shows in red in your message list.  To change the color coding, go to Edit > Preferences > Mail & Newsgroups > Labels


Back to top

 

Deleting mail and Managing Trash

To delete mail, select one or more messages and click the Delete button, or press the Delete key on the keyboard.


(Trick: if you have trouble getting a message to delete, exit Mozilla and go back in. Before clicking on the message to delete it, click the dotted part of the dividing line between the list of messages and the message display, so that the message list takes up the whole screen. Delete the message and compact the folder. Then click on the dividing bar to re-open the message panel.)

A word about the Trash folder: As part of mail management, it may be tempting to consider storing needed email in the trash folder. Whether it is the Windows desktop Recycle Bin, or the MacOS desktop Trash can, or the Trash folder within the email program, the TRASH is not an ordinary location. It represents space that is occupied by something no longer needed; space that is specifically marked to be reclaimed. In other words, items in the trash have been DELETED. Items in the trash continue to exist only to allow for possibly undoing the deletion in case it was done by mistake (and users should not count on the grace period for deciding to undo this mistake to last for too long). It should not be a shock when items in the trash are lost; presumably, that's why they were put there. If the real need is for a temporary storage location for items that are pending review, see Creating New Folders for instructions on creating a separate location for that specific purpose.

Back to top



Filters

Examples: LISTSERVs and SPAM

Example 1: Listserv messages moved to another folder

A mail filter is used to automatically move, delete or forward your incoming e-mail messages based on pre-set criteria. For example, you may want to have all e-mail coming from a certain person, organization or listserv filed in a separate folder for later viewing. To create a mail filter, click Tools > Message Filters, then click the New button. Give your filter a name, choose the filter criteria and an action to take on those messages. When finished creating your filter, click OK, then close the Message Filters box. Below is an example of a filter that moves mail from the Lehigh WIRED listserv to a folder called wired-i.

 

Example 2: SPAM messages moved to Trash:

A popular filter is one that moves SPAM messages to the Trash folder (or some other folder to be reviewed later).   The following example shows the criteria used to move SPAM to Trash. To create a spam filter, click Tools > Message Filters, then click the New button. Name it Spam Filter and then set the filter criteria and an action to take on those messages. When finished creating your filter, click OK, then close the Message Filters box. Note: Some users like to create a mail folder called "Spam" and move messages there, instead of deleting it. It's a matter of personal preference how you act on spam.

Back to top

Folders

Take control of your mail by using folders

If you tend to keep hundreds (or even thousands!) of messages in your Inbox, consider building a folder system.  You may find moving messages out of your Inbox and into other folders increases the likelihood of finding messages more quickly when you need them.  At the same time, it helps keep you from exceeding your Inbox quota.

Creating Folders
To create a folder, click File > New > Folder. Choose where to create the new folder. Your choices are either on the mail server, represented by UserID@lehgih.edu, or on the hard disk, represented by "Local Folders." Note: If you file a lot of email in Local Folders, remember to backup frequently.

Type in the name of the folder to create and click OK. Note: Avoid using slashes or an apostrophes in your folder names.

Moving messages into Folders

To move a message into a folder, select it, click the File button in the Toolbar and choose either YourUserID@lehigh.edu or Local Folders. Clicking YourUserID@lehigh.edu displays all of your folders on the mail server. Local Folders shows just the folders on your hard disk.  Select the folder where you want to move the message. If you don't have a File button in your Toolbar, see Other settings to add one (selecting what buttons to show in the toolbar) .

You can also use the drag-and-drop method when filing messages into Folders. Target the drops carefully, though!

 

Back to top

Sending mail

To create a new message click on the Compose icon.

To reply to an existing message, click on Reply or Reply All icons. (Reply All sends a message to everyone the original message was sent to.) [Tip: if you have your mail set to put > in front of the replied message, but it's wrapping oddly, you can go to the Options menu and choose Rewrap.]

Enter the email address(es) to send to in the address box. If you are entering multiple addresses, drag/drop or separate with commas. Note that you can choose different types of addressing, including To:, CC:, BCC: (BCC means send a copy to this person but don't include that person's address in the message the TO and CC recipients get). You can choose Reply-To, also, to have replies sent to another address.

Type in the Subject in the Subject line and the body text in the main section.

When you are ready to send the email, click the Send button.

 

Back to top

Templates

If you find yourself retyping the same sorts of messages in response to routine requests, create a message without addressing it and save it as a template. File > Save as > Template. Then when you need to reply with that message, go to your Templates folder, double-click the template message, address it, edit if necessary, and click Send. Templates remain in the templates folder until or unless you delete them.

Back to top

Spell checking
You can use spellchecker on an "as needed" basis via the Spell button on the Composition window Toolbar.  If you want to spell check every message you send, click Edit> Preferences> Mail & Newsgroups > Composition and place a checkmark in the box for "Check spelling before sending" and click OK.

Back to top


Attachments

To attach a file to an email message, click on the Attach icon in the composition window.   Select the file you want to attach and click Open. The file name will be displayed in the list of attachments in the upper right of the Composition window. To remove an attachment before sending, click on it and press the Del key, or right-click the filename and choose Delete.

Back to top

Other settings

Sending Mail as Plain text:

Forwarding as Inline rather than attachments:
From Edit, go into Preferences, expand Mail and Newsgroups, Composition.  When you choose "Inline" you have an opportunity to edit the forwarded message, such as when you want to remove irrelevant text from the original message.  When you choose "As attachment" there is no opportunity to modify the text of the forwarded message.  It is sent in its entirety.

Setting the Mail Start page:  
From the Edit menu, choose Preferences, and select Mail and Newsgroups. Enter the URL for the page you want in the Mail Start Page box.

Selecting what buttons to show in the toolbar:

By default Mozilla will display certain buttons on the toolbar. Two useful buttons that are not displayed by default are File and Print. To add these and other buttons, go to Edit > Preferences > Mail & Newsgroups.  Check each box on the right that you want displayed as a button on the toolbar.

 

Back to top

How to configure the LDAP (Lehigh) directory to autocomplete addresses

In order to be able to use the Lehigh directory to look up people's email addresses, you will need to set it up as an LDAP directory in Mozilla.

To do that, click Edit > Preferences > Mail & Newsgroups > Addressing

Click on the Edit Directories Button.

Click the Add button.

Back to top

 

Address books and mailing lists

Importing an address book (exported from Netscape previously)

Note: address books need to have been exported in LDIF , comma delimited (csv) or Tab delimited text formats.

Creating a mailing list in the Address book
In the Address book, to create a new mailing list, select an address book on the left hand side to create the mailing list in. Then click the New List icon. Give the  list a name, and an nickname (the short version that you will type in the TO: part of your messages). Then paste or type the addresses into the mailing list; if you type names, Mozilla will search your address books for address cards that match.

Saved email addresses
Mozilla will try to save the email addresses off the latest incoming and outgoing mail you've used Mozilla for. If you go into Edit and choose Preferences (from inside address book) you can turn this off or increase or decrease the number of addresses to save. These addresses are saved in the 'Collected Addresses' address book.

Back to top

Last updated: September 19, 2006

kmm3